Synfire Pro Windows and Dialogs
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Background

This collection of screen shots of user interface windows and dialog boxes in Synfire Pro Version 1.66
build #3 was captured in a Windows 7 64 bit environment in February 2013 by Robert Wheeler, a Synfire
user. The interface may look different in a Macintosh computer environment.

This is not an official Cognitone document. The interface design is copyright Cognitone and is presented
here only as a supplement to the official Synfire User Manual and as a learning and reference resource
for Synfire users.

Although most windows and dialog boxes have been captured, this document does not claim to be
comprehensive. Many of the windows and dialog boxes can be opened in multiple ways. This document
attempts to document some of the ways. Some windows have multiple sub-tabs. Not all sub-tabs are
displayed in this document.

Although the interface components are grouped as “windows” and as “dialog” elements, classification
has been arbitrary. “Dialog” has been used for interface boxes that don’t have a visible menu in the
Windows environment and that have fewer interactive elements. “Window” has been used mostly for
interface boxes that do have a visible menu when opened in the Windows environment.

“Ctrl” has been used as an abbreviation for the Windows “control” key. In Macintosh environment this
would be the “command” key. The “+” symbol indicates holding down the first key and next key
simultaneously. The “>” symbol indicates steps to follow in a sequence of menu choices. The “=>"
symbol indicates that the prior menu choice should result in opening the window or dialog box.
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Arrangement window

Empty, ready for entering or importing content:

' Arange: New Arrangement B

File Edit Container Instrument Phrase Parameter Transform View Playback V w Help

New Arrangement

“51"-'"“3“‘5 Progression  'Harmonizer  Mixer - 2 46 B 1216 432 M - |h ...h 2 —

™ Parameter "5“- Container

(o]

Instrument Label:
Time

New Arrangement | :':‘":1 FSOIR anges | Mise
1 s Null Sound | .

Harmony Browse... Global Setup...
Take Type: Shared Rack

Figure Port
Transpose 'F} Mull
Chromatic

Layer

Lyrics

Velocity
Length
Step
Shift
Rhythm

tic Fiano

no sound assi
se button to s
Interpretation

Morphing
Variation

Volume
Pan
Reverb

Pause

Overdub

How to open Arrangement window
Run Synfire program (arrange is default window when program runs)

Double click program icon => OR
Start > Programs > Cognitone > Synfire => OR
My computer > C: > Program files (x86) > Cognitone > synfire > synfire.exe => OR
Arrange window > File > New > Arrangement (Ctrl + N) => OR
Arrange window > File > Last Used File > click file => OR

Launcher window > Arrange =>
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Arrange window displaying example content included with Synfire:

nt Phrase Parameter Tran

Fancy Piano And Guitar °

nstn.lmenls Pri

‘arameter | [nstr.

G
o Time:

Fancy Piano And Guitar Tempo

1 = Piano ST SM setframe Rate
Harmoeny 24 FPS

Take

Figure
Transpose
Chromatic
Layer
Lyrics

Guitar Velociy
Length Relative Time
Step
Shift
Rhythm
Interpretation
Morphing

Variation

Volume
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Instrument Tab

nstrum
om0 BT

File Edit Container Instrument Phrase Parameter Transfc

Fancy Piano And Guitar *

AEEEEE -E

—
™ ‘Paramete: NS ' ontainer

f Instrument Label:

Time Piano
Tempo

Scheme

——
Sound
Harmony i Global Setup...
2 ¥
Take hared Rack
Figure
Transpose
Cnromatic
Layer
Lyrics.

Velocity

Interpretation
Morphing
Variation

WVolume:

Overdub
¥ synch

Instrument sub-tabs (sg

b a

nd, ranges, misc.)

_ _
™ 'Parameter 'INSIY Contatner *° ™ Parameter IASERT Container

—— Note: the Ranges function can be found in
nstrument Label: Instrument Label:
Time Piano Fiano multiple places:

Tempo T b ——
Scheme WANgESY [Misc Sound Range. |MiSC

Harmony e widdle Upper

e [nstrument tab

Controllers

Avtiulstions.. e Mixer tab, instrument sub-tab

Take

Figure

Transpose Store Sound Properties o AUdio & MIDI Setup Windowl DeVice
e descriptions tab

Lyrics . .

. e Audio & MIDI setup window, Global

instruments tab

e Instrument properties dialog

m

e Arrange window buttons

Interpretation retation

e i e Scaleboard dialog buttons

Variation

Volume
Pan

Accept From Sound
Reverb

00:00.00

Page 6



Guitar

Page 7

| W Tempo
L]

Parameter  Instr, “E“E'

Piano And Guitar
Length:
am 16m
Keep Child Containers in a Row
Comments:
Play around with different symbol

s within the same figure and
see what their effect is.




Parameter Area
The parameter area consists of the parameter block and the parameter inspector.

] X
T - = ~ | 3 2 6 8 1216 2432 M — |h ...h a -

—
M (Parameter! [nctr. Container

- = = = = = % Time

Fancy Piano And Guitar ° Tempo

| ]
Scheme eading Preset

Snapshot | Delete Template

1 s =n Piano
Harmony
Intervals

Fold

Take
o= ! [ v Octaves
g8 B~ £ o | A
¥ 1 / [ Y A BEN| C
i v \ ! Transpose
L \
e e — _P _:__ - — ! Moncphonic

= Chromatic -
egato
= Layer L

Lyrics
Tie Motes

Guitar Velocity ] Corpletion

Length Inversions
St Alignment
= smoothing
=it Hints

g Syntnesis;  Auto-Chords

Interpretation
Morphing
“ariation

Volume
Pan
Revert

Overdub
¥ synch

Parameter block and parameter inspector tab
Note: parameter inspector has sub-

= . tabs for some parameters.

Tempo

Scheme

Harmony

m Containe !
Parameter| Tnstr. Container T e ——— Parameter | ;. iner

Tempo Harmony

Scheme |
Time Snapshot| Delete | e Snapshot  Delete Template | &of|
Time snapshot Delete  Template

Tempo Scheme

Harmany

Tempo
Scheme - P
Scheme Signature: 4/
Harmony
Harmony Halftime

orrection

Feel: # Straight

Shng Vertical
Horizontal
Relation

Key

Estimate

Parameter block sections expand or colla ¢lick on section header; use mouse wheel to scroll
parameter block when necessary. Inspector'content varies depending on parameter selected.
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Progression tab:

ancy Flano And Guiar =

O A W B T T.IT.1
Instruments | PFOGIESSION | ' Jarmoni ! : y e

T
| Base Progression

© 7o

F#7 Bm7

Chord: C
Vertical: C.ionian
Horizontal: ~ C.major
P -
Chord % Relation: C.Major
Global: E.Minor
Numeral: VI
Function: 1G, sP
Edtensions:  (add2) (2ddd) 6 maj7 (addd)

1) SRATONE 1 TR AW T O

[ ]
o Harmony

Overdub

;- ®

Progrbs (harmony, scheme, layer, scale selection preferences)

i Harmony

Length:
121

Harmony

]
Scale Selection Preferences Harmeny

Prefer Standard Modes v Create ad-hoc Horizontal Scales
¥ Incdude Horizontal Scale Variants v Smooth Transitions

A N ——
IociERREmatRE el s Traditional | Aftemnative Strict
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Harmonizer tab
Arrange window, click Harmonizer tab OR
Menu, Phrase > Harmonize => (caution, this approach opens tab, not separate window)

Fancy Piano And Guitar °

Tnstruments | Progressior | | Hermonizer | | fier LAY

Rendered hotes

Piana

Guitar
Retain Harmony
Match Neighborhood

¥ Optimize Scales Chord: [

Vertical: C.ionian

Horizontal:  C.major

Bass: -

Relation: C.Major

Global: E.Minor

Numeral: VI

Function:  tG, sP

Extensions:  (add2) (add4) 6 maj7 (addd)

6(add4) maj7 (add4) 6(2dd9) maj7 (9) maj7 (13}
Scales
Octaves
MIDLin
be @ P ; 0000

Overdub

Prob
rone ¥ synch
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Mixer tab:

ancy Piano And Guitar °

Instruments

faster ficrosoft
Internal GM Synth

ram.

Instrument L
1

Volume Volume Volume

Piano

———
Sound | R

Pan Fan Fan
Reverb Reverb Global Setup...

Pause Pause

< Pial

rand

T Guitar

Overdub

Mixer sub-tabs (sound, pinges, misc.)

—
Parameter | Inst Param:

I nt Lal
Piano

Instrument Label:

Piano

— —_r
nd 'Ranges’ s ; Miee

Middle Upper
Contraller

Articulatio

Store Sound Properties

—
Parameter | .4

Figure

Snapshot  Delete

Accept From Sound
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Launcher window
Menu > Window > Launcher =>

Synfire Pr...

Arrangement

Library
Phrase
Phras
Pro
Palette
Sketch

Catalog

Setup

Panic
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Audio & MIDI Setup window

How to open Audio & MIDI Setup window

Ctrl + Shift + A

Launcher window, [Setup] =>

Menu, Playback > Audio & MIDI Setup ... =>

Preferences window, Instruments Tab, Audio & MIDI Setup section, [Open Setup Window] =>
Catalog window > Playback > Audio & MIDI Setup ... =>

Device Descriptions tab
|| Audio & MIDI Set

—
File Edit

Ports E CEEC“N ns Global Instruments

d Manufacturer: ies: Selected 5 d

Internal GM Synth Internal Template
e i Mame:
Multi-Timbral A = Drur .
--Effects

General MIDI Bank

D420

deueEdddd

A.Tubular Bells
Julcimer |||||
Jrawbar Organ

HName:

General MIDI Bank

Auto [Programs, ¥ ¥ GM
v Reset CC

Manual

men
eneral MIDI Wavetable
integrated with k

match your operating W 0
e

environment.

QUL

MIDI Input

OR
OR
OR
OR
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Ports tab
Content displayed will depend on attached equipment and installed plug-ins.

|| Audio & MIDI Setu
] C ]

File Edit Host Port D

Global Instruments Settings

Shared Rack 'R
t Name: oaded Plugin: ) 0dB  -INF df
2- A-PRO Output Only =
MIDI Port

2- A-PRO 1 Input Only
MIDI Port

Gain

2- A-PRO 2 Input Only
MIDH Py D - )
Internal GM Synth

2- A-PRO MIDI IN Input Only
MIDI P

2- A-PRO MIDI OUT Output Only
MIDI Port

Microsoft GS Wawvetable Output Only Internal GM Synth
Synth

P | Probe MIDI Input Status

Shared rack subtab

File Edit Device Bank Cal nd Help

C .
Horts

INF gt

Device Descripti
Internal GM Synth

Reset | Panic | W
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Global instruments tab

|| Audio & MIDI Setu
L —

File Edit Host Port Device Bank tego und ew dow Help

Global Instruments

Sound” Ran

Generic Chords 3 Gui Metronome Brow

il il il
Shared Rack

Probe Probe Probe Probe Probe Probe
GM.Acoustic ynthString | GM.Acoustic GM.Acoustic GM.Drumkit GM.Drumkit

Grand sl Guitar(steel)

set to Defaults

Sub-tabs (sound, ranges, mix)

onome

Accept From Sound
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Settings tab

il

File Edit Host Port D Cate Sound

al Instruments
MIDI

ntrollers on Sound Selection
mpensate Latency During Recording
v erify MIDI Input Port on Startup
v Lse Audio Engine For MIDI Input
v MIDI Through

Dynamic Sound Management
T Disable
v Always Adopt Sound Properties
Mute Unknown Sounds

Audio

v Use Audio Engine

v Launch Engine Already on Startup

Prefer € it Engine
Manually Shutdown Engine
v Fast Loading

Preferences Window

How to open Preferences window
Menu, Edit > Preferences =>  Tabs: License, User interface, Files, Defaults, Scales, Instruments, Online

License tab

Alrieerid

r—1
License”| ' Jcer Interface  Files Defaults Scales Instruments  Online

rare License

Product:

Document

ight:

All rights reserved.
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User Interface tab

]
UserInterface = Defaults

Inverse: Dark [Default)

Double Buffering

Tool Tips Vector Selection Resets Playhead
Delete Key in Vector Mean lear”
Immediately Select a Mew Container
Cpen Plug-In Editor After Loading

ndows in Background
on Instrument

Language Off

Progress Bars

English Deutsch Over Individual Vectors
Ower Entire Sheet
In the Structure

Swap Monitors

Full Screen Drag & Drop

Reveal Experimental Features

Files tab

b\Documents'Synfi ig Browse...

b\Documents\Synfire Pro Browse...

Automatic Backup

ypond.exe

-dgui {format} -o {outfile} {infile}

Debugging

indows\notepad.exe {filename}
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Defaults tab

Prm—— -

Defaults es Instruments 'Online

Tolerate Triple Sharps/Flats
Use German H for B and B for Bb

Don't Merge Equal Chords

Scales tab

o pteenes

terface ' Files ults | 'S€aIESY 7 qstry line

¥ Create ad-hoc Horizontal Scales
v Smooth Transitions

v A ive Scale Sets o :
Include Alternative Scale Set: f o —— e

Instruments tab

e

User Interface Files 'Defaults ales  Instruments

AIDI Setup

COpen Setup Window... NOte: OpenS AUdiO & MIDI Setup
window

Online tab (how often program looks for updates)

IR e

Files' 'Defaults Instruments

* Weekly
Monthly
Never
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Library window

Menu, File > New > Library

| |Z| Library .
File gi.w.- Folder Pool
Playback

| b

Pool 'Phrases Parameters

Harmony
Figure

Rhythm Velocity
Length Step
Shift

Interpretation Morphing

Phrase Window
Menu, File > New > Phrase => OR
Menu, File > Convert > Extract Phrase =>

I 2 s e 220 gewr

File Edit ainer Instrument Phrase Parameter Tra

. - -
Y |1 2 4 6 81216 24 A - - 7 | tength: 4m Figure

Scheme Transition Take Transpose Layer Velocity Rhythm Interpretation
Harmony Figure Chromatic Lyrics Length S Morphing
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Phrase Pool window
Menu, File > New > Phrase Pool =>

|Z| Phrase Pool: New Phrase Pool
e

File Edit ument Phrase Parameter Transform

— Fi
> 1 4 3 |12 A - = [ Length; 4m igure

Scheme Analysis Take Transpose Velocity 1 Interpretation Wolume Reverb Figure ST

Harmony Transition Figure Length Wariation Pan Pause

——— o
Phrases | 1, nation Properties | (i

Loop: Mame: | Take:

Opening Preview Phrase
Loop ‘Working Template
Eridge

Closing

Tempaorary

Palette window
Menu, File > New > Palette =>

@ Palette: C.Major
File Edit L

Freeze
MIDI Input

LD Dsusd
Tsus4
Tsus4
Asus2

Am
mi
m3
]
Caug Ddim Eaug i —
C7 m7ES) Edim 65
2 Ddim7# m7(BS) L)
C7zusd Dm7x5) E(b5) At
7(05) (add2)
: (]
B 7
(add3)
6(add9)
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Progression window
Menu, File > New > Progression =>

|z| Progres

Edit

File

o

O
Base Progression

Harmony

Sketch window
Menu, File > New > Sketch =>

File Edit Instrument Ph
r—
Parameter | InStr
T
Figure
Rhythm

Transp.

ument Label:

Reverd
Pan
Volume

Variation
Interpr.
Revern
Pan
Volume:

TF Null

pt
ll Device

Mull Sound

New Sketch
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Convert to Sketch window
Menu, File > Convert > Create Sketch =>

| 1

Harmany

Scheme Figure
Trans. Rhythm
Interpr Transp.

Revern Variation
Pan Interpr.
Volume Reverb
Pan

Null Sound

New Arrangement (copied)

Extract Progression window
Menu, File > Convert > Extract Progression =>

|Z| Progression: Progressio
—

File Edit Section Parameter Transform Vi
8 16 MNew Arrangement

]
Base Progression

]
Harmony

Chord

Bb7

Bb.tydian-b7
D.Minor

ion Preferences

Probe

Bb?7

Bb.hydian-b7
D.Minor

Harmony

D.Minor
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Catalog of Chords and Scales window
Menu, Edit > Catalog of Chords and Scales =>

@ Catalog

File Edit ltem View
ical Scale

dim

dim7

mi(b5)

m

mG Prefer
mi —

Name:

Comments:

LULLLILLILL]

Similarities

Equivalents and Ext
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Dialog Boxes

Open dialog (open project, rack, libraries, palettes, phrases, files, ...)
Ctrl+ 0O OR

Menu, File > Open =>

Any File (*.7)

B backups
mples
Arrangements
phing (Pro)

fiom
-
=
=
=]

Save dialog
Menu, File > Save =>
Menu, File > Save as =>

Any File (*.
Parent Folder

M Racks

New Arrangement.cognac

Save

Parent Folder

phing (Pro)
Tools
Arrangement Demo 1.cognac
Chanel Mo 5.cognac

nac

Fancy Piano And Guitar.cognac
Orchid Project (Orchestral).cognac
Smooth Edit.cognac

OR

Create Folder

Notes:

Claims: Al rights reserved.

Compressed
Locked

¥

Incl. Screen Set

Content:
System:
From:
Date:
Author:
Editors:

Motes:

Claims:

Incl, Screen Set
Incl, Sketch
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Open MIDI file dialog
Menu, File > Import > Standard MIDI file => OR
Menu, Phrase > Import ... =>

|| Open Standard MIDI File

¥ Standard MIDI File (.mid) ¥ Standard MIDI File Format:

Parent Folder

Export MIDI file dialog
Menu, File > Export > Standard MIDI file => OR
Menu, Container > Export > Standard MIDI file =>

|| save Standard MIDI File

¥ Standard MIDI File Format:
Create Folder Simultaneous Tracks
¥ Program Changes Optimize for Notation
Reset Controllers Global Key Signature
Chords
Container Structure

Comments:

New Arrangement.mid

Save
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Export MusicXML dialog
Menu, File > Export > Notation MusicXML... => OR
Menu, Container > Export > Notation MusicXML

|| Save MusicXML Notation File

¥ AnyFile (*%)

Parent Folder Create Folder

Comments:

New Arrangement.xml

Save

Export LilyPond dialog
Menu, File > Export > Notation LilyPond ... => OR

Menu, Container > Export > Notation LilyPond
E‘ Save UIyPona Notation File

1l
\"

Any File (%)
Parent Folder Create Folder

%Ml Examples -
-

yrigh
obert Wheeler
Ed

Comments:

Mew Arrangement.ly

Save

Scale Selection Preferences dialog
Menu, Edit > Scale Selection Preferences =>

V' Prefer Standard Modes V' Create ad-hac Horizontal Scales

V' Include Horizontal Scale Variants ¥ Smooth Transitions

v ‘Include Altemative Scale Sets Traditional = Alternative Strict
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Container Rename dialog
Menu, Container > Rename =>

Kip

Enter New Mame

New Arrangement

Instrument Properties dialog
Menu, Instrument > Properties =>

All Connected Devices

# Instrument

Null Sound

£ Guitar
£ Organ
# Other

et+Harpsichord
Electric Piano

Solo | Probe

Instrument Articulations dialog
Menu, Instrument > Articulations =>

>> Device Description  '>> Sound

Null Sound
Off: (optional)

Number: ON Value: OFF Value:

0 0 0

Program Change
0

Latency (ms):

0 Default

Cancel
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Instrument Controllers dialog
Menu, Instrument > Controllers ... =>

]
scription | > und | => Instrument

Null Sound

Mame: Controller Number: Default Value (optional):
000 Bank Select [MSE) 0 Reset
000 Bank Select | 0 Default Value
000 Bank Select | 0 Default Value
000 Bank Select ( 0 Default Value
000 Bank Select (MSE) 0 Default Value
000 Bank Select (MSE) 0 Default Value
000 Bank Select [MSE) 0 Default Value
000 Bank Select | 0 Default Value

Vaolume Enable 90 Default Value

Fan Enable Default Value

Circle of Fifths dialog

Menu, Window > Circle of Fifths =>

aeorrivs - 57

Harmonic Content dialog
Menu, Window > Harmonic Content =>

Chord: C

Vertical: C.ionian
Horizontal  C.major
Bass: _

Relation: C.Major
Global: C.Major
MNumeral: I

Function: T
Extensions:  (add2) (add4) 6 maj7 (add9) 6{addd)
maj7 (add4) 6(addd) maj7 () maj7 (13) maj7(9,11)
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Fretboard dialog
Menu, Window > String Instrument => OR
Menu, Window > String Instrument (landscape) =>

(" Tr——— @

Tuning

Mode

Tuning Mode  jifEsl <

Keyboard dialog

Menu, Window > Keyboard =>

Scales
Octaves
MIDI-in

Scaleboard dialog

Menu, Window > Scaleboard =>

12 16 24 32 Pause Mew h ...b a —

st St
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Console dialog
Menu, Window > Console =>

Loading iglser> Racl rrentRack.cogsetup I
Loading Sketch: 14 Fil

Loading i

Loading

Loading

Loading

Loading

Loading Sketch: 2 Files)

Ready

Shortcut modifiers 11 invalid on this platform (ke

Shorteut modifiers 11 invalid on this platform (ki

Shortcut modifiers 11 invalid on this platform

Shorteut modifiers 11 invalid on this platform

Shortcut modifiers 11 invalid on this platform (k

Shorteut modifiers 11 invalid on this platform

Loading <pathConfi unings (String Instrument: 10 Files)

About dialog
Menu, Help > About =>

| Synfire Pro 166 Build #3 (Windowis 7 e[ (]

-
Synfire ~o
Music Prototyping Studio !
Copyright Cognitone GmbH, Germany. All Rig

This software is protected by copyright law and international treaties.

Unauthorized reproduction or distribution, whether as a whole or in part, may

result in severe criminal or civil penalties and will be prosecuted to the maximum
xtent possible under law.
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